История версий

MonKipOrg.
Мониторинг КИП. Организация.
История версий.

4.7.0.0
Добавлены функции автоматического анализа и вывода статистики базы, по таким критериям как:
сколько приборов, какого типа и с какими характеристими имеется в базе. Отображение и вывод этой подробной информации в документ Word. Улучшена работа с облачной FTP базой. Исправлены ошибки, касаемые Demo версии.

4.6.6.9
Исправлен Интерфейс, улучшена работа приложения в демо режиме.

v. 4.6.1.7
Некоторые косметические правки кода.
v. 4.6.1.6
Некоторые правки в FTP модуле. Более подробная информация о базах.
v.4.6.1.4
Важное сообщение.
Информация для незарегистрированных пользователей:
Для общения с Автором программы не используйте
ведомственные E-Mail адреса Вашей организации.
На такие адреса автор не сможет ответить.
(подробно в Меню "Помощь")
v.4.6.1.3
Fixed
Ускорена отправка и получение базы с FTP за счет удаления некоторых сообщений. Заменен архиватор. Исправлена ошибка.

v.4.5.1.1
Переработан и улучшен экспорт в Excel, согласно изменениям программы. Получаемые файлы настроены для печати.
На вкладке "База и Графики" по умолчанию загружается таблица всей базы. Нужный тип графика загружается кнопками на выбор.
В меню программы добавлены иконки. Исправлены ошибки.
v.4.5.0.0
Вкладка "Вся приборная база" переименована как "Паспорта и Фото" её наполнение и функциональность не изменились.
Вкладка "График" стала называться "База и Графики". Кроме построения графиков поверки на эту таблицу можно вывести всю приборную базу (кнопка справа) с полной локализацией каждого прибора по таблицам и Объектам.
Улучшен вывод таблиц в Excel и Word. Улучшен прямой вывод на принтер.
На эту же вкладку перенесён поиск прибора.
Поиск теперь возможен по одному слову в выбранной колонке таблицы, а не по полному совпадению текста. Поиск слова диференцирован по колонкам таблицы.
v.4.4.0.0
Серьёзная доработка интерфейса.
В таблице "Вся приборная база" указывается где конкретно установлен прибор.
Если он находится на вкладке СЛАД, то указывается номер строки с прибором.
Если установлен на объекте, то указывается Объект и Параметр контроля прибором.
Эту же информацию можно видеть и в таблице "График поверки".
Ширина таблиц теперь более гибко реагирует на разрешение вашего монитора.

v.4.3.0.0
Горизонтальная прокрутка всех таблиц.
Таблицы стали многострочными. Отображается три строки.
Остальные можно увидеть после экспорта в файл.

v.4.2.0.0
1. Добавлена функция планирования контрольной проверки манометров:
При вводе нового прибора в базу приложение автоматически запланирует через полгода контрольную проверку манометра на месте, контрольным манометром. В графе "Контрольная проверка и примечания" впишет напоминание с датой контрольной проверки. *Только для манометров.
2. На объектах можно ставить отметку о выполненной контрольной проверке манометра.
3. Для выполнения контрольной проверки необходимо предварительно создать список контрольных манометров на вкладке "Объекты".

v.4.1.1.4
Колонка параметров, левая часть таблицы объектов, значительно расширена. Длинные имена параметров стали умещаются лучше.

v. 4.1.1.2
Сетевая сборка программы.
Несколько изменён интерфес программы.
Жесткий режим запрета редактирования при получении базы из FTP хранилища со статусом "только для чтение". Редактировать такую базу возможно локально при переводе программы на локальный режим работы: (Не использовать FTP).
Такую базу, локально отредактированную, вернуть обратно в общее хранилище невозможно. Она останется либо локальной, либо, выгрузив её в новое хранилище, организовать новую ветку с базой на FTP в другой директории хранилища.
Информативность FTP клиента расширена.
Добавлена кнопка SOS для аварийного восстановления базы в хранилище из архивов, хранящихся в директории хранилища.
Исправлены баги.

v. 4.1.0.0
Несколько изменён интерфес программы.
Добавлена вкладка работы с FTP хранилищем.
Жесткий режим "только чтение" при получении базы из FTP хранилища. Редактировать такую базу возможно локально при переводе программы на локальный режим работы: (Не использовать FTP).
Такую базу, локально отредактированную, вернуть обратно в общее хранилище невозможно. Она останется либо локальной, либо, выгрузив её в новое хранилище, организовать новую ветку с базой на FTP в другой директории хранилища.
Информативность FTP клиента расширена.
Добавлена кнопка SOS для аварийного восстановления базы в хранилище из архивов, хранящихся в директории хранилища.

v. 4.0.98.42
После получения с FTP, редактируемой кем-либо в настоящий момент базы (Read Only), редактирование полностью блокируется. Такую базу можно только просматривать, но изменить, даже локально, нельзя.
FTP клиент стал более информативен при восстановлении архива на сервере.

v. 4.0.96.41
Программа стала сетевой, многопользовательской.
Хранение базы возможно на сервере FTP. Доступ к приборной базе имеет любой пользователь организации, однако, единовременно полным доступом, т.е. правом редактирования может обладать только один из них. Остальные пользователи в это время могут только просматривать базу. (Read Only).
Наравне с возможностью хранения приборной базы в сети Интернет, функция локальной работы сохранена. Пользователь может работать с базой на своё усмотрение как локально, так и через Интернет хранилище.
Это обновление ставится поверх имеющейся версии, и как новая установка. Наработанная ранее база сохраняется.

v.3.1.18.72
Изменения:
Примечания к приборам теперь можно не только создавать и очищать, но и редактировать.
Для Demo режима 100 приборов в базе бесплатно и без регистрации. Без триального срока.
Для увеличения размера базы потребуется регистрация.
Увеличена минимальная разрядность номеров приборов до 18 символов.
Ввод в ячейку периода поверки теперь возможен и с клавиатуры.
Добавлена кнопка очистки полей ввода перед редактированием.

v.3.1.18.70
Изменения:
Улучшена совместимость с широкоформатными мониторами НОУТБУКОВ:
разрешение монитора по горизонтали не менее 1280
разрешение монитора по вертикали не менее 768.

v.3.0.18.35
Изменения:
Предельное количество приборов во вновь создаваемых таблицах объектов увеличено до 100 шт. Объекты, созданные ранними версиями программы будут иметь прежние возможности. Для увеличения объема старой таблицы следует создать новый объект и перенести в него все приборы через таблицу "Приборы КИП и А СКЛАД".
Примечания к приборам теперь можно не только создавать и очищать, но и редактировать.

v.3.0.18.34
Перед установкой этой версии следует удалить Demo версию.
Зарегистрированным пользователям ставить поверх предыдущей версии.
Изменения:
Расширены возможности в демо режиме.
Программа полностью бесплатна до заполнения базы сотней приборов.
Для увеличения объема базы потребуется регистрация.

v.3.0.18.33
Оптимизирована работа счетчиков статуса поверки приборов.

v.3.0.18.32
Теперь под контролем программы вся информация о поверке.
Во все таблицы добавлены счетчики приборов годных к эксплуатации.
На панель общих счетчиков добавлены счетчики годных к эксплуатации приборов по разделам.
Панели интерфейса получили названия.
Программа ведет лог событий в хронологическом порядке. Эта опция доступна на вкладке ОТЧЕТЫ.
На таблице истории СИ можно отследить историю действий над любым прибором выборочно.
Оптимизирован экспорт таблиц в Word.
Доработана форма отчета о поверке приборов.
Добавлены возможности настройки программы.
Исправлены ошибки ввода параметров на объектах.
Несколько изменен интерфейс.
Новая развернутая справка.

v.2.8.18.10
Во все таблицы добавлены счетчики
приборов "Без поверки".
На панель общих счетчиков добавлены счетчики
приборов "Без поверки" по разделам.
Более удобная форма отчета по базе.

v.2.7.18.59
Во все таблицы добавлена колонка "Класс".
При обновлении программы база будет конвертирована в новый формат автоматически.
Теперь дата поверки прибора устанавливается как календарная дата, однако для отображения её в таблицах, можно выбрать в настройках варианты как календарный вид, так и поквартальное отображение даты поверки. Межповерочный интервал теперь вводится помесячно, а не по годам.
Программу можно настраивать под себя. Добавлена опция "Настройки".
Стало возможным защитить паролем удаления не только приборов, но и объектов и Внешние связи.
Пустой пароль - нет защиты удалений паролем.
Изменения наименования параметров в таблицах Объектов теперь сохранять не требуется.
Колонка параметров в этих таблицах пересохраняется автоматически, без участия пользователя, т.е. "Налету".
Улучшен вывод в Word, Excel и на печать. Шаблон вывода в Excel имеет 65 страниц с таблицами. (более 3000 приборов).
Программа строит графики поверки средств измерений по месяцам выбранного года.
График поверки можно редактировать и сортировать:
по: "Месту установки СИ", по "Наименованию СИ", "Типу и марке СИ" и по "Дате поверки СИ"
Создание, редактирование, сохранение и печать паспортов приборов.
Создание, редактирование, сохранение и печать паспортов комплектов приборов.
Каждому типу приборов можно присоединить его фотографию в таблице "Вся приборная база". Там же эти фотографии можно посмотреть, выполнить поиск нужного прибора по номеру или другому текстовому условию поиска..
Работа над Интерфейсом программы:
Улучшен интерфейс таблицы "Вся приборная база",
добавлена вкладка "График поверки",
изменения в верхнем меню.
В настройках можно выбирать скины интерфейса.
После обновления Админский пароль будет сброшен. Обновите свой пароль на удаление приборов.
Перерегистации лицензии программы не требуется.

v.2.6.17.14
Работа над Интерфейсом программы.
Расширена возможность работы на мониторах до 2k.

v.2.6.17.10
Добавлено автообновление выпадающих списков параметров приборов КИП при добавлении прибора в программу.
Кнопку "+" нужно использовать только, если параметр добавляется в список без создания прибора.

v.2.6.17.05
Для метролога добавлен "Конструктор внешних связей" для самостоятельного формирования им различных списков с приборами в разные внешние поверочные и ремонтные организации. Этот раздел также выводится на экспорт и в печать.
Улучшен антидубликатор названий объектов.
Некоторые изменения в интерфейсе программы.
Добавлен экспорт в MS Word таблиц объектов.

v. 2.5.17.32.
Добавлено множество визуальных счетчиков приборов.
Добавлена вкладка "Отчет о поверке приборов".
Добавлена вкладка "Вся приборная база".
Добавлен поисковик прибора по критериям.
Добавлен экспорт в MS Word и прямая печать любой таблицы.
Оптимизация под Windows XP и новее.
Запуск с правами Администратора автоматический.
Небольшие изменения в интерфейсе.
Исправлена ошибка в антидублекаторе номеров приборов.

v.1.9.15.41 Модернизированная версия.

v.1.9.15.40 Beta версия.

v. 1.0.0.0 - 1.9.0.0 Проектные разработки по заказу конкретной организации.

Системные требования:
Windows All. (From Windows XP to Windows 10)
Microsoft Office 2003 and latter.
Разрешение экрана по ширине от 1152 до 2k.
Разрешение экрана по высоте от 768.

EminSoft- 2022
http://kinovideo.narod.ru/eminsoft.html


Назначение программы

Мониторинг КИП. Организация.

Назначение программы.

Основное назначение программы - Мониторинг за приборами КИП на крупном предприятии или организации. Эта версия позволяет работать с базой локально и в многопользовательском режиме. База может храниться локально или на FTP.
Программа предназначена для метрологов предприятий и руководителей служб АСУТП, cлужб КИП и А и прочих структур предприятия, связанных с эксплуатацией приборов КИП и автоматики, при выполнении ими задач по метрологическому обеспечению организации или эксплуатации средств измерений непосредственно на объектах организации.
Программа отслеживает появление новых версий.
База данных программы несовместима с базой данных программы "Мониторинг КИП Предприятие" этого же автора, т.к. имеет иные алгоритм работы и архитектуру базы данных.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Интерфейс

Мониторинг КИП. Организация.

Интерфейс.
Интуитивно понятный интерфейс программы условно разделён на два раздела:
Раздел Метрологии и Инженерный раздел. Разделение очень условное, т.к. и Инженер КИП, и Метролог предприятия имеют доступ и необходимость работать со всеми вкладками программы в необходимых им объемах.
Всего программа имеет 9 вкладок. Некоторые функции, используемые на вкладках, дублируются в верхнем меню программы.

Верхнее меню.
Назначение пунктов верхнего меню:

Администратор.
Доступ к настройкам выполняется через верхнее меню программы.
В настройках можно настроить и выбрать:
Наименование Вашей организации,
Название Вашего подразделения (Лаборатории),
Способ отображения в таблицах даты поверки - поквартальное или календарное.
Выбрать скин,
Размер лога программы.
Задать пароль администратора (защита от удаления приборов).
Начать работать в сети Интернет. (хранить базу на FTP сервере).
Отказаться от использования сети, работать локально.
Работа с архивами.
Этот пункт позволяет создавать и удалять архивы состояния приборной базы или выполнять откат состояния на имеющуюся точку отката.
Объекты - дополнительный доступ к одноименной вкладке.
Внешние связи - дополнительный доступ к одноименной вкладке.
Помощь - регистрация программы, доступ к справке, поиск обновлений, сведения о версии вашей копии программы.
Выход - выход из программы.
Программа снабжена множеством счетчиков в нижней части окна программы:
Состояния поверки, количества приборов, объектов и организаций.
Счетчики установлены на каждой вкладке.
Счетчики сумм этих данных.
Программа имеет свой инсталлятор- деинсталлятор.
Запускается от имени Администратора компьютера.

Вкладки:

1. ПРИБОРЫ КИП и А СКЛАД.
Это вкладка с которой начинается программа и с которой Инженер КИП или Метролог приступят к работе в ней. Это самая функциональная вкладка программы. Здесь средства измерений начинают свой путь по приборной базе и здесь же заканчивают.
В нижней части окна, на панели КАТАЛОГ расположены поля ввода данных приборов. Этот каталог можно пополнять как вручную, так и автоматически. По мере ввода новых приборов в базу данных с новыми данными о них, списки каталога пополняются автоматически. На этой же вкладке выполняется редактирование средств измерений и удаление их из базы. После внесения в базу, прибор можно переместить на любую доступную вкладку программы, тем самым, обозназначить его место и статус.
Подробно о работе на вкладке.

2. Приборы КИП и А в ПОВЕРКУ.
Время идет, годность поверки прибора завершается или прибор приходит в негодность. Инженер КИП снимает прибор с эксплуатации и переносит его на эту вкладку. Только с вкладок Приборы КИП и А в ПОВЕРКУ и Приборы КИП и А в РЕМОНТ метролог может переместить прибор в свою часть программы для отправки в Гос. Поверку или ремонт, а по возврашении из поверки возвращает только на владку ПРИБОРЫ КИП и А СКЛАД.
Подробно о работе на вкладке.

3. Приборы КИП и А в РЕМОНТ.
Неисправные приборы снимаются с эксплуатации и переносятся Инженером КИП на эту вкладку. Метролог организации сам решает дальнейшие действия с прибором. Ему также доступна эта вкладка для загрузки средства измерения в свою часть программы.
Подробно о работе на вкладке.

4. Приборы КИП и А на СПИСАНИЕ.
Назначание вкладки понятно без объяснений. Приборы, не пригодные к дальнейшей эксплуатации, необходимо списать с баланса. Приборы физически списывают не по одному, а актом списания некоторого количества приборов. На этой вкладке накапливается этот список и выполняется списание. Прибор удаляется из базы с пометкой в логе программы "Списан". Пометка ставится в таблице специальной вкладки, о которой позже.
Подробно о работе на вкладке.

5. ОБЪЕКТЫ.
Вкладка - конструктор для Инженера КИП.
Приборы организации не лежат только на складе, а устанавливаются для выполнения своих функций на точки измерения. Точки измерения расположены на определенных объектах предприятия (котлы, вент. системы и пр.). Для обладания полной информацией о месте нахождении конкретного прибора, на этой вкладке Инженер КИП создает "Объект" с необходимым наименованием, на объекте именует точку отбора параметра для этого прибора и помещает его на объект простым переносом строки с прибором с нужной таблицы. Название объекта можно менять. При необходимости, объект можно удалить, предварительно очистив его от имеющихся приборов. Программа не допустит удаления объекта с приборами. При физической замене прибора непосредственно на объекте, его нужно переместить на нужную вкладку программы, а на его место переместить вновь установленный прибор с нужной таблицы.
Подробно о работе на вкладке.

6. ВНЕШНИЕ СВЯЗИ.
Все приборы, покинувшие Вашу организацию по любым причинам должны быть перенесены на эту вкладку.
Эта вкладка - конструктор для метрологов предприятия.
Организации Гос. поверки и ремонта не обладают универсальными возможностями и принимают в работу приборы определенного типа или группы. Метролог Вашей организации создает на этой вкладке таблицы с наименованием конкретных организаций и переносит в них приборы для отправки. По возвращении из поверки или ремонта, он редактирует данные поверки прибора в таблице, вносит понятные примечания и возвращает их инженеру на СКЛАД.
Подробно о работе на вкладке.

7. Паспорта и фото.
Паспорта и фото.
Это сборная таблица всех приборов и объектов Вашей организации, отображаемая в одном окне программы. Приборы в таблице организованны в порядке размещения их на всех вкладках программы, включая приборы, размещенные на всех объектах. даже если эти таблицы не отображены в настоящее время.
Здесь можно создать, редактировать и распечатать паспорта приборов и их комплектов и присоединять к каждому типу приборов их фотографии.

Подробно о работе на вкладке.

8. ОТЧЕТЫ.
Эта вкладка работает в трёх режимах:
"Отчет о поверке", "Лог событий", "История СИ".
На ней отображаются отчеты:
а) Состояния поверки средств измерений по всей базе.
б) Лог событий в хронологическом порядке.
в) История каждого СИ от его включения в базу до удаления из неё.
Подробно о работе на вкладке.

9. База и Графики.
Вкладка предназначена для Инженеров и Метрологов организации.
На таблице этой вкладки можно строить графики поверки приборов на выбранный год. Гибкое управление графиком позволяет создавать и редактировать графики, выводить их на печать.
Здесь же организован поиск нужного прибора по единственному слову в его расположении, наименовании, типе, по номерам..
Подробно о работе на вкладке.

10. FTP хранилище.
Вкладка предназначена для работы с хранилищем базы, распологаемом на FTP сервере по Вашему выбору. На этой вкладке возможно создание хранилища с базой, получение базы общего доступа, а также обслуживание хранилища.
Подробнее на страницах справки: "FTP доступ" и "Нештатные ситуации"

Системные требования:
Windows All. (From Windows XP to Windows 10)


Ограничение в пробной версии

Ограничения в пробной версии.
Период испытания программы не ограничен по времени.
Количество приборов в базе данных ограничено 10 шт.
Этого достаточно для испытания программы.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Регистрация программы

Мониторинг КИП. Организация.

Регистрация программы.

Регистрация программы проходит в два этапа:
1. Запрос ключа регистрации по электронной почте из-под интерфейса программы.
2. Ввод регистрационных данных.

1. Запрос ключа регистрации:
В верхнем меню главного окна программы выберите:
Помощь > Регистрация > Запросить ключ регистрации.
Заполните все поля: "Название организации",
Назовите себя.
Выберите один из способов оплаты лицензии.
Только все заполненные поля позволят вам сделать запрос. Нажмите кнопку в середине окна.
В текстовом поле ниже сформируется текст запроса на покупку ключа регистрации. Копирование текста из окна программы невозможно.
Нажмите "Сохранить файл". Файл Request.txt будет сохранен в выбранном Вами месте.
Его нужно отправить вложением на адрес, указанный в первой строке файла.
Если на Вашем компьютере отсутствует возможность работы с электронной почтой, то сохраните сгенерированный текст запроса в файл и отправьте его с доступного компьютера.
Важно!
Регистрационный ключ будет пригоден только на компьютере, сгенерировавшем запрос Request.txt и, никак не связан с иными компьютерами.
Автор программы, получив такой запрос, сгенерирует ключ регистрации программы для конкретного компьютера и сообщит Вам реквизиты для оплаты регистрации.
После получения подтверждения от банка о поступлении средств или реального получения суммы оплаты, Вам будет выслан ключ регистрации на указанный Вами адрес электронной почты с инструкцией.

2. Регистрация программы:
После получения ключа регистрации запустите программу и в верхнем меню выберите:
Помощь > Регистрация > Зарегистрировать программу.
Заполните все поля полученными данными и нажмите OK.
Помните! Для успешного завершения регистрации желательно "копировать и вставить" данные через буфер обмена. Ошибка даже в один пробел или символ не в том регистре не даст положительного результата.
Программа перезапустится автоматически и, в случае успеха, в заголовке главного окна программы появится название Вашей организации, и все функциональные ограничения будут сняты.
В окне "О программе" будет также указана Ваша организация как владелец лицензии. Накопленная ранее приборная база сохранится.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Лицензионное соглашение
на использование программы
EminSoft
"Мониторинг КИП. Организация".

Внимательно прочитайте!
Настоящее лицензионное соглашение является юридическим документом, заключаемым между Вами, физическим или юридическим лицом, и мной, т.е. EminSoft", относительно указанного выше программного продукта EminSoft, включающего в себя программное обеспечение, записанное на соответствующих носителях, любые печатные материалы и любую "встроенную" или "электронную" документацию. Устанавливая, копируя или иным образом используя программу, вы тем самым принимаете на себя условия настоящего соглашения.
Если вы не принимаете условий данного соглашения, то вы не имеете права использовать данную программу.
Программа защищена законами и международными соглашениями об авторских правах.

1. Авторское право.
Все права собственности и авторские права на программу и в отношении ее принадлежат EminSoft. Все права собственности и авторские права на продукцию, созданную программой принадлежат законным владельцам ключей регистрации.

2. Права пользователя.
Настоящее соглашение дает вам нижеследующие права:
Использование и копирование программы. EminSoft предоставляет вам право использовать такое количество копий программы, которое соответствует числу имеющихся у вас законно приобретенных ключей регистрации программы.
Разрешается создавать копии программы и использовать их на всех компьютерах, на которых она законно зарегистрирована. Разрешается также делать копии программы для целей архивации и резервного копирования.
Все права собственности и авторские права на продукцию, созданную программой принадлежат законным владельцам ключей регистрации.
Вы соглашаетесь с тем, что обновления данной программы, выпускаемые EminSoft, могут быть платными за пределами мажорной версии. Например если вы являетесь обладателем регистрации на версию 1.9.15.41, то обновление до версии 2.0.0.0 может потребовать дополнительной оплаты. При этом, такие обновления существенно дешевле покупки новой версии.
Разрешается навсегда уступить все свои права по настоящему соглашению третьим лицам, при условии, что вы передаете также все имеющиеся у вас ключи регистрации программы и программа не будет переустановлена на другой компьютер.

3. Ограничения.
Вы имеете право использовать незарегистрированную программу неограниченное время.
Вы соглашаетесь с наложенными на программу функциональными ограничениями при таком варианте её использования.
Приобретая ключ регистрации к программе, Вы соглашаетесь с тем, что ключ регистрации будет пригоден только на том компьютере, для которого он сгенерирован.
Следует сохранять или воспроизводить все уведомления об авторских правах на всех копиях программы и созданных ей документах.
Запрещается передавать программу и ключи регистрации к ней третьим лицам для установки на другой компьютер, что является бесполезным действием.
Запрещается вскрывать технологию и декомпилировать или модернизировать программу. Все права на модернизацию программы принадлежат EminSoft.
Использование программы должно осуществляться в соответствии с действующим законодательством.

4. Прекращение действия соглашения.
Все предоставленные вам в отношении данной программы права автоматически анулируются при прекращении действия лицензионного соглашения об использовании программы EminSoft, либо, если EminSoft прекратит действие настоящего соглашения (без ущерба для каких-либо своих прав) при несоблюдении Вами условий и ограничений данного соглашения. При прекращении действия соглашения вы обязаны уничтожить все имеющиеся у вас копии программы и ключи регистрации.
Поводом для прекращения действия данного соглашения могут стать также попытки фальсификации Вами данных для обновления регистрационного ключа.

5. Отказ от гарантий.
EminSoft не несёт никакой ответственности за нанесенный ущерб, физическому или юридическому лицу при использовании данной программы, в том числе прямой или косвенный.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Обновление программы

Мониторинг КИП. Организация.

Обновление программы:
Поиск новых версий и обновлений программа выполняет автоматически. Для этого необходимо подключение к Интернету. Однако пользователь имеет возможность ручного поиска и загрузки обновлений из меню программы. Воизбежание повреждения приборной базы при обновлении, внимательно читайте информацию инсталлятора.
Появилась возможность настраивать программу под себя.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Первый запуск

Мониторинг КИП. Организация.

С чего начать:
 Запустите программу из программной группы "Мониторинг КИП. Организация". Программа запускается очень быстро даже при размере приборной базы в несколько десятков тысяч приборов.
Программа, создаст архивную копию состояния базы, актуальную на момент текущего запуска.
Откроется главная таблица - Приборы КИП и А СКЛАД. Вы не сможете изменить имена некоторых вкладок. Однако при создании и переименовании объектов, загружаемых на вкладку ОБЪЕКТЫ, и организаций на вкладку ВНЕШНИЕ СВЯЗИ, названия вкладок будут изменяться в соответствии с названием загруженной в настоящий момент таблицей.
Это мощный конструктор в руках Инженера КИП и А и Метролога.
Вы можете создавать и управлять неограниченным количеством объектов и внешних организаций, а также контролировать состояние поверочных дат каждого прибора в отдельности и общую информацию в целом. Программа составляет за вас графики поверки на любой год. Эти графики непосредственно в программе можно редактировать, экспортировать в Excel и Word, а также напрямую выводить на принтер.
Так же программа позволяет создавать и распечатывать или экспортировать в файл паспорта приборов и паспорта комплектов приборов.
Каждому типу прибора можно присоединить его фотографию *.JPG. Программа использует копии Ваших графических файлов, сохраняя их в своей директории - Photo. Эта директория служебная. При замене вами или удалении, закрепленной за прибором фотографии эту директорию обслуживает программа без вашего вмешательства в директорию Photo.
Итак:
Программа запущена.
Как пополнить базу приборов и список каталога.
читайте на странице Приборы КИП и А СКЛАД.
Как работать с базой корпоративного доступа читайте на странице FTP доступ.

Системные требования:
Windows All. (From Windows XP to Windows 10)


FTP доступ

Мониторинг КИП. Организация.

Хранить базу возможно как локально, так и удаленно, на FTP сервере. Локальное расположение базы не требует подключения к Интернету. Для хранения приборной базы в Интернете с целью многопользовательского доступа к ней, Вам необходимо иметь свой доступ к любому FTP серверу на Ваш выбор.
FTP клиент уже встроен в программу MonKipOrg, начиная с версии 4, и установка стороннего клиентского модуля для работы программы не требуется.

Доступ к базе по FTP.
Если у вас нет доступа к какому-нибудь FTP, то зарегистрируйтесь на FTP хостинге для хранения приборной базы.
Откройте вкладку "FTP хранилище".
*Кириллица и пробелы недопустимы. Регистр символов на всех хостингах имеет значение.
Эти данные автоматически сохранятся или можно их сохранить вручную.
Если это первый Ваш вход на FTP, то нажмите "Создать хранилище". Если директория создается Вами, то директория с указанным именем будет создана на FTP и в неё автоматически будет выгружена, имеющаяся у Вас приборная база. База на Вашем компьютере очистится полностью для приема базы с сервера. Это нормальное состояние базы при работе с удаленной базой. Если эту директорию хранилища создали до Вас, то Вам будет отказано в создании одноименной директории.
С этого момента база на сервере имеет статус полного к ней доступа до тех пор, пока один из пользователей не загрузит её с сервера на свой компьютер. Этим пользователем может быть любой, имеющий доступ по логину и паролю к директории хранилища.
Загрузив базу на свой ПК, Вы сможете работать с ней с полными правами доступа, т.е. редактировать или просматривать.
До тех пор, пока база находится на одном из клиентских компьютеров с целью редактирования, т.е. с полным доступом, ей на сервере присваивается статус Read Only, т.е. другие пользователи смогут также загрузить базу к себе и даже попытаться редактировать, но это не возможно, т.к. редактирование будет полностью блокировано. Вернуть обратно такую базу на сервер они также не смогут. Она так и будет загружаться вместе с каждым запуском их программы, до тех пор, пока пользователь, обладающий монопольным правом не закончит редактирование и не выйдет из своей программы. При выходе из программы с загруженной с правами полного доступа базой, она автоматически выгрузится на FTP сервер. Базу статуса Read Only можно загружать в любое время, а для редактирования она должна быть свободна на сервере.
База будет автоматически возвращена на сервер FTP только в одном случае: пользователь, клиент, получивший базу в полный доступ, просто закрыл свою программу. База отправится обратно на FTP и ей будет присвоен статус полного доступа.
Кнопки типа: "Отправить базу на FTP" нет. Интеллект программы сам за Вас всё определит и решит.
В режиме Read Only с базой одновременно могут работать столько пользователей, сколько их имеется в Вашей корпоративной группе, а с правами полного доступа только один - первый счастливчик. Это предотвратит параллельное редактирование, которое может привести к коллапсу базы.
Встроенный в программу FTP клиент позволяет создавать несколько директорий для хранения баз, но интеллектуальный модуль FTP клиента не позволит вернуть базу не в директорию-источник, т.е. подменить базу. Если Вы будете использовать иные директории, то запоминается только последняя из них .

FTP клиент.
FTP клиент размещен на новой вкладке "FTP хранилище".
Если это первый запуск FTP клиента, то он откроется с чистыми полями для ввода параметров входа на сервер. Заполните поля ввода, они сохранятся как при ручном сохранении, так и при успешном создании директории FTP хранилища.
Не допускаются: кириллица и пробелы, а также символы, недопустимые в именах файлов и директорий.

Кнопка "Создать хранилище".
Нажмите на кнопку "Создать хранилище". Если все данные введены правильно, то на Вашем FTP будет создана директория и имеющаяся у Вас в настоящий момент приборная база будет в неё выгружена. Не нужно пугаться, что у Вас в приложении больше нет базы. Это нормально, ведь Вы выложили её в общее пользование и для работы с ней нужно её загрузить к себе в приложение MonKipOrg на общих основаниях.

Кнопка "Показать лог файл."
На сервере ведется лог обращений пользователей к базе. Нажав на эту кнопку, Вы получите список с обращениями к базе с указанием даты, времени, IP и имен компьютеров, которые её редактировали и вернули обратно. По этому логу можно понять свободна ли она и, кто и когда из Ваших коллег в ней работал. Получение базы для просмотра не фиксируются в логе, т.к. изменений базы не происходит.

Кнопка "Проверить статус базы".
Нажав на эту кнопку, Вы легко определите доступность базы для редактирования или просмотра.

Кнопка "Список файлов на FTP".
Эта кнопка FTP клиента позволяет быстро определить статус базы на сервере.
В нормальном состоянии на сервере не может быть менее четырех файлов:
собственно базы, упакованной в zip архив, двух её резевных копий,
файла Log.tx со следами редактирования базы.
Еще один файл - Busy.txt появляется в хранилище в случае. когда её кто-нибудь редактирует. Само название файла переводится как "Занят", что отражает статус доступности. Когда пользователь вернет базу на сервер, этот файл удаляется с сервера, что означает : Полный доступ.
Определение валидности базы на сервере может понадобиться при сбоях по сети во время передачи базы. Base.zip и две копии базы должены быть всегда. Log.txt - должен быть всегда. А вот файл статуса Busy.txt - является показателем доступности базы для редактирования.

Кнопка "Получить базу с FTP".
Эта кнопка FTP клиента позволяет в любой момент получить базу к себе в пользование, но статус доступа может отличаться от полного до ReadOnly.

Локальная работа с базой.
Использование хранилища на сервере не является обязательным.
Вы можете не использовать FTP, как и в ранних версиях программы, а хранить базу локально только на своем ПК.
Поля входа на FTP сервер будут свободными от данных до тех пор, пока вы не станете его использовать.
Вариант: - "Работал локально и хочу присоединиться к общей базе со своей базой" не сработает.
Кнопки "отправить базу" не существует. Интеллект модуля FTP предотвратит подмену баз.
Чтобы присоединиться к имеющейся базе нужно сначала её получить с сервера правами полного доступа. При этом Ваша локальная база будет затерта базой, полученной из общего источника и потеряна навсегда.
Чтобы работать с базой общего пользования только локально нужно сначала получить эту базу со статусом Read Only, а затем выбрать в главном меню "Не использовать FTP". Эту базу Вы уже не сможете вернуть или присоединить к общей базе. Кнопки "отправить базу" не существует. Вы можете на основе этой локальной базы создать новую ветку на этом или другом FTP, в новой директории. но смешать несколько баз из разных веток и директорий в одну не получится. Интеллект FTP клиента этого не позволит.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Нештатные ситуации

Мониторинг КИП. Организация.

Нештатные ситуции:
При сбоях в работе сети во время приема./передачи файлов базы могут случиться неприятности. Файл отправлен не до конца, файл базы неисправен или вообще исчез с сервера. Такую ситуацию можно исправить как программно, так и вручную.
Файл лога сомостоятельно восстановится и начнет запись сначала.

A) Программное восстановление базы на FTP.
MonKipOrg создает удалённо расположенные архивные копии базы в двух ситуациях:
1. При получении базы любого статуса на компьютер.
2. При отправке на сервер базы, полученной с правами полного доступа.
Эти две резервные копии и служат архивами базы.
Откройте FTP клиент из группы меню "Администратор".
Нажмите на кнопку SOS. Это Ваша спасительная кнопка вызова модуля восстановления.
Выберите архивную копию для восстановления и нажмите "Восстановить".
База будет восстановлена на FTP из архива. MonKipOrg отчитается о выполнении.
Закройте FTP клиент. Откройте MonKipOrg и загрузите базу к себе на компьютер.

B) Ручное восстановление удаленно расположенной базы на FTP.Откройте MonKipOrg.
1. Найдите у себя в локальном архиве баз нужную вам сборку, т.е. "Откатить состояние из архива". Убедившись визуально, что именно эта база Вас устроит.
2. Сторонним клиентом FTP, например FTP comander, зайдите на свой FTP и удалите полностью Вашу рабочую директорию, к примеру "My_ShareFolder".
3. Из-под MonKipOrg обычным способом запустите встроенный FTP клиент.
4. Если поля входа на FTP не заполнены (а они должны быть заполнены), заполните их прежними данными для входа на сервер.
5. Нажмите кнопку создания хранилища.
Хранилище на сервере будет создано и в него отправится восстановленная из архива база. База на компьютере очистится. Это нормально.
Теперь можно работать с базой, загрузив её с сервера.

С) Если ничего не помогает. Семь шагов спасения:
Может так случиться, что при передаче базы с или на сервер, произойдет сетевой сбой. Приложение не успеет выполнить все, положенные процедуры и программа может даже отказаться запускаться.
Это решаемая проблема, ведь у Вас есть Локальный архив баз на компьютере.
Ваши действия:
1. Найдите в директории программы C:\Program Files\EminSoft\MonKipOrg папку с архивами базы BackUpData и скопируйте её в любое место. Она поможет восстановить базу.
2. Удалите программу MonKipOrg полностью. При удалении программы, деинсталлятор спросит о файлах, созданных после инсталляции MonKipOrg . Согласитесь на их удаление.
3. Зайдите сторонним клиентом FTP на свой FTP сервер и полностью удалите директорию с Вашей базой (например My_Base_Kip).
4. Установите MonKipOrg и выполните регистрацию имеющемся у Вас ключом регистрации.
5. Теперь скопируйте обратно в директорию с программой папку BackUpData, с заменой имеющейся и запустите программу.
6. Штатным способом Выберите актульный архив и восстановите локально базу.
7. На вкладке FTP хранилища заполните необходимые данные для входа на сервер и нажмите "Создать хранилище".
Локальная база скопируется на сервер.
----------------------------------------------------------
Если вознинут трудности - обращайтесь к разработчику. EminSoft@Mail.ru

Системные требования:
Windows All. (From Windows XP to Windows 10)


Приборы КИП и А СКЛАД

Мониторинг КИП. Организация.

Приборы КИП и А СКЛАД.
С этой таблицы начинается прибор, здесь выполняется его ректирование и здесь он может завершить своё существование в базе.

Добавление прибора в базу программы.
Программа запущена. Каталог и таблица "Приборы КИП и А СКЛАД" пусты.
В нижней части окна программы расположена панель КАТАЛОГ.
Заполните все поля списков каталога и нажмите справа, в трехкнопочном блоке кнопку "Добавить".
Если все поля, обязательные к заполнению, содержат текст, то в таблице появится строка с прибором и назначенными ему характеристиками. Списки каталога пополнятся автоматически. В следующий раз достаточно будет выбрать из выпадающего списка нужную строчку. Списки каталога также можно пополнять и редактировать вручную маленькими кнопками (+) и (-) справа от выпадающих списков.
Примечание к прибору можно добавить в процессе добавления прибора или дополнительно, в любое время.

Редактирование.
Иногда требуется изменить данные в добавленном приборе, например при ошибочном вводе.
Для редактирования выделите в таблице нужную строку с прибором.
В списках Каталога найдите или введите нужный текст.
Нажмите кнопку Редактировать.
В строке прибора данные будут заменены.
Обратите внимание, что поля списков каталога, оставленные пустыми, не внесут изменений в ячейки таблицы. Вы можете отредактировать выборочно отдельную ячейку прибора, так и все его данные в один клик. Списки каталога не пополняются автоматически вновь введенными значаниями при редактировании. Если нужно добавить новое значение и в каталог, то предварительно сохраните его в списке, при помощи кнопки (+).
Кнопка (-) удаляет из списка каталога выделенный в этом списке текст.
Программа не позволит дублировать заводской или инвентарный номера. Все номера также заносятся в память базы и за ними ведется контроль. При ошибочном вводе уже существующего в базе номера, программа сообщит об этом.

Ввод данных о поверке.
Данные о поверке прибора заносятся при добавлении нового прибора. Однако, это значение также подлежит редактированию.
При добавлении нового прибора следует указать интервал поверки в месяцах и выбрать в календаре дату поверки. Если при добавлении прибора календарь останется пустым, то и ячейка о поверке также останется пустой и окрасится в серый цвет. Это означает, что прибор без поверки. Это можно исправить при редактировании, задав интервал и выбрав в календаре дату поверки.
При редактировании можно редактировать независимо:
дату поверки, интервал поверки или оба значения в один клик редактора. Можно также полностью очистить ячейки поверки прибора, задав в редакторе нулевой интервал поверки.
При редактировании данных программа переспросить о ваших намерениях.

Удаление прибора из базы.
Эта процедура может потребовать ввода пароля Администратора, если таковой задан в настройках.
Выделите строку с нужным прибором.
Нажмите кнопку "Удалить" или "СПИСАТЬ СИ".
После подтверждения строка с прибором будет удалена.
Из базы программы удаляются также заводской и инвентарный номер этого прибора. Эти номера можно будет вводить вновь при добавлении других приборов.
Программа не имеет корзины удаления и не удаляет их в корзину Windows.
Восстановить случайно удаленный прибор нельзя. Потребуется новое добавление прибора с нужными данными.
Однако, возможен откат состояния базы к предыдущему её состоянию, но в этом случае будет восстановлено состояние не только одного прибора, а всей базы по выбранной точке восстановления из архива программы.

Сохранение состояния базы.
Вам никогда не потребуется сохранять состояние приборной базы, т.к. эта процедура выполняется в фоновом режиме, автоматически после любого Вашего вмешательства в базу программы. Прибор автоматически заносится в базу программы или исключается из неё, пересчитывается количество приборов, объектов, внешних организаций и пр.
Все счетчики всегда на виду.
Под постоянным контролем состояние поверки каждого средства измерений в реальном режиме времени. Состояние поверки в таблицах окрашено в соответствующие цвета, что удобно для восприятия человеком.

О раскраске ячеек со статусом поверки:
Годная поверка - нет окраски.
Срок истекает, осталось. до 30 дней - желтый цвет.
Срок поверки истек - красный цвет.
Без поверки - серый цвет.
Эта же цветовая схема применена для счетчиков на интерфейсе всех вкладок.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Приборы КИП и А в ПОВЕРКУ

Мониторинг КИП. Организация.

Приборы КИП и А в ПОВЕРКУ.

Назначение:
Прокси вкладка для временного хранения приборов, срок поверки которых истек или истекает.
По мере эксплуатации сроки поверки приборов завершаются. Переместите на эту вкладку приборы, предназначенные в поверку. Метролог предпиятия, составляя график поверки, учтёт их при отправке госповерителю.
Составляя документы для сопровождения приборов в Гос. Пповерку, он переместит эти приборы на свою вкладку "Внешние связи", а по возвращении, отредактирует данные поверки приборов и возвратит их Инженеру на "СКЛАД".

Системные требования:
Windows All. (From Windows XP to Windows 10)


Приборы КИП и А в РЕМОНТ

Мониторинг КИП. Организация.

Приборы КИП и А в РЕМОНТ.

Назначение таблицы:
Прокси вкладка для временного хранения приборов, требующих ремонта на внешних предприятиях.
По мере эксплуатации приборы выходят из строя и требуется ремонт. Переместите на эту вкладку приборы, предназначенные в ремонт. Метролог предпиятия, составляя график поверки или ремонта, учтёт их при отправке госповерителю или в ремонтную организацию..
Составляя документы для сопровождения приборов в Гос. Поверку, он переместит эти приборы на свою вкладку "Внешние связи", а по возвращении, отредактирует данные поверки приборов и возвратит их Инженеру на "СКЛАД".
Приборы, не подлежащие дальнейшей эксплутации, метролог отметит в примечании к ним и переместит на "СКЛАД". Инженер КИП и А перемещает их на вкладку для списания, если этого требует ситуация. Далее выполняется стандартная процедура списания прибора с баланса предприятия, после чего прибор списывается и из базы программы.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Приборы КИП и А на СПИСАНИЕ

Мониторинг КИП. Организация.

Приборы КИП и А на СПИСАНИЕ.

Прокси-вкладка предназначена для временного хранения приборов, предназначенных на списание с баланса предприятия.
Со временем, приборы устаревают, приходят в негодность и их нужно списать.
Списание на предприятии выполняется не часто и не по одному прибору, а актом.
Переместите приборы в таблицу этой вкладки и сохраняйте их здесь до физического списания их по акту. После физического списания их с баланса предприятия их можно удалить из базы навсегда. При этом в логе программы будет зафиксировано не удаление из базы а именно списание прибора.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Объекты

Мониторинг КИП. Организация.

ОБЪЕКТЫ.

Ваша организация эксплуатирует некоторое количество объектов. На каждом из них, на точках отбора установлены приборы. Эта вкладка предназначена для контроля за объектами и приборами на них.

Создание таблицы объекта:
Выберите в верхнем меню "Объекты". Откроется чистая одноименная вкладка.
Введите название объекта и нажмите "Создать".
Будет создана пустая таблица, а название вкладки заменится названием объекта. Левая серая колонка этой таблицы и есть те самые точки отбора параметров объекта. Клик по строке в ней разрешит её редактирование.
Введите имена параметров объекта. Эту колонку можно отредактировать и в любое время.

Пополнение объектов приборами .
Все перемещения строк с приборами между любыми таблицами выполняются методом Drag & Drop. Перетащил и бросил. Траектория дропа - треугольник: Источник > Заголовок > Приемник.
Перейдите, например, на вкладку СКЛАД,
Зацепите курсором мыши строку. Курсор изменит свой вид на зачеркнутый круг.
Не отпуская кнопку, потащите курсор на заголовок вкладки с именем созданного объекта. При наведении на заголовок вкладки курсор снова поменяет свой вид на лист бумаги со стрелкой, выделится заголовок и откроется вкладка - приемник. Не отпускайте кнопку.
Дотяните курсор мыши на строку напротив выбранного параметра отбора (строку на объекте можно предварительно выделить) и отпустите кнопку. Всё! Строка из таблицы перемещена в новую таблицу на нужную позицию напротив наименования точки отбора.
Поступите так с остальными точками отбора.
Если при переносе вы отпустили кнопку не в том месте, т.е. прервали Drop, то вернитесь в таблицу - источник и повторите попытку. При неуспешно завершенном Drop'e строка останется в таблице истосника.
Если вы перенесли строку не к тому параметру объекта, то придется таким же образом вернуть её на место и внимательно повторить перенос. Движение строк внутри таблиц запрещено, т.к. все таблицы можно сортировать по разным критериям, а таблицы с объектами - особые таблицы. Каждый прибор может стоять только напротив своего параметра и строки в таблице никакой сортировке не подлежат, чтобы не было путаницы.
В местах, недоступных для переноса, курсор принимает вид зачеркнутого круга.
Перемещение между другими таблицами выполняется несколько иначе.
Загрузка объекта на вкладку.
Перейдите на вкладку ОБЪЕКТЫ.
Выберите в выпающем списке нужный объект и нажмите "Загрузить объект".
Список может содержать неограниченное количество объектов. Переключаясь между ними, вы мониторите объекты организации.

Переименование объектов.
Войдите на вкладку ОБЪЕКТЫ.
Выберите нужный.
В нижнее поле введите новое название объекта.
Нажмите "Переименовать объект".
Дублирование имен программа не допустит.

Удаление объекта из базы.
Удаление объекта выполняется также, как и переименование, но с одним отличием: Объекты можно переименовать даже если они содержат приборы, а удалить объект с приборами программа не позволит.
Перед удалением объекта следует переместить из него приборы в другую таблицу. Только освобожденная от приборов таблица может быть удалена из базы. При попытке удалить объект с приборами, программа откроет таблицу объекта и предложит освободить её от приборов. После перемещения приборов из таблицы объекта снова войлите на вкладку ОБЪЕКТЫ через верхнее меню, выберите в списке объект и нажмите "Удалить".
Удаление объектов, как и приборов, может быть защищено паролем Администратора программы. Это позволяет защитить базу от случайного удаления приборов и объектов или неквалифицированного обращения с базой.

Замена приборов на объектах.
При необходимости сдачи в поверку или ремонт, приборы следует заменять на поверенные. Физическую замену приборов на объектах следует отражать в программе.
Допустим, что вы заменили на объекте один прибор другим.
Переместите строку со снятым прибором на нужную вкладку программы, а на его место известным способом переместите новый. Таким образом положение дел на местах будет синхронизировано с базой программы.
В колонку "Примечание" можно добавить запись о событии.

Контрольная проверка манометров.
Для внесения в графу примечаний отметки о выполнении контрольной проверки манометров необходимо предварительно создать Объект "Контрольные манометры", внести в него манометры всех необходимых пределов измерений с классом не ниже класса установленных манометров.
Выделите строку с манометром, внизу окна выберите календарем дату выполненной контрольной проверки. Дата будет вписана в графу примечаний со ссылкой на контрольный манометр из списка контрольных.
Приложение не будет вносить отметку о контрольной проверке других типов средств измерений.
Такие отметки нужно вносить вручную, т.к. периодичность контрольной проверки у всех типов различна.
Графа примечаний, при необходимости, также подлежит редактированию.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Внешние связи

Мониторинг КИП. Организация.

ВНЕШНИЕ СВЯЗИ.

*Все приборы, физически покинувшие Вашу организацию по любым причинам должны быть перенесены на эту вкладку. Так вы сохраните контроль за своими средствами измерений.
Эта вкладка - конструктор для метрологов предприятия.

Работа в разделе "Внешние связи":
Основное назначение этого конструктора - формирование списков приборов КИП для отправки в поверяющие организации по группам. В каждый список включаются только те приборы, которые поверяются конкретной метрологической организацией.
Создание, переименование и удаление организаций не отличается от работы в конструкторе объектов.
Инженер КИП, в ходе своей работы, переносит просроченные или неисправные приборы с объектов на прокси вкладки "В поверку" или "В ремонт". В них скапливаются приборы различных типов. Однако универсальных поверителей нет. Каждая поверочная организация имеет лицензию на поверку или ремонт опреденных типов или групп приборов. Вот здесь и выручает конструктор внешних связей.

Заполнение таблицы.
Создайте таблицу с именем поверяющей организации.
Перенесите в неё из вкладок "В поверку" или "В ремонт" только необходимые приборы.
Откройте таблицу - источник. Разрешено перемещать только с вкладок "Приборы КИП и А в ПОВЕРКУ" и "Прибры КИП и А в РЕМОНТ".
Захватите курсором мыши нужную строку.
Не отпуская кнопки мыши, перетащите курсор по траектории треугольника:
Исходная строка > Заголовок вашей таблицы > Верхняя пустая строка вашей таблицы.
Отпустите кнопку мыши.
Прибор перемещен в предварительно загруженную таблицу организации внешней связи.
Таблица перенумеруется, счетчики внизу таблицы изменят свои значения.
Сохраните, отредактируйте и распечатайте список. Используйте его для контактов с поверителем.
По возвращении из поверки приборов, отредактируйте в этой же таблице даты поверки, внесите примечания и верните приборы на вкладку "Приборы КИП и А СКЛАД". Перемещение обратно выполняется по тому же принципу.
Далее ими снова займется Инженер КИП.

Переименование организаций.
Войдите на вкладку ВНЕШНИЕ СВЯЗИ.
Из выпадающего списка выберите организацию для переименования.
В нижнее поле введите новое название.
Нажмите "Переименовать организацию".
Дублирование имен программа не допустит.

Удаление организации из базы.
Удаление организации с приборами невозможно.
Удаление организации выполняется также, как и переименование, но с одним отличием:
Организацию можно переименовать даже если она содержит приборы, а удалить её с приборами программа не позволит.
Перед удалением организации следует переместить из него приборы в таблицу Приборы КИП и А СКЛАД. Только освобожденная от приборов таблица может быть удалена из базы.
При удалении организации может потребоваться пароль Адмнистратора программы на удаление.
Это позволяет защитить базу от случайного удаления приборов и организаций или неквалифицированного обращения с базой.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Паспорта и Фото

Мониторинг КИП. Организация.

Таблица "Паспорта и Фото".

 Эта таблица для полного обзора всей базы программы. Здесь можно увидеть любой прибор базы, но какие-либо действия над ним не допускаются.
Эта таблица обновляется всякий раз, при обращении к ней. Она читает данные из всех таблиц базы, даже не открытых в настоящее время. Строки в таблице разделены цветом, что позволяет легко в ней ориентироваться. Приборы расположены так же, как и в своих таблицах и сгруппированы по таблицам, объектам и внешним организациям. Объекты и внешние организации расположены в алфавитном порядке.

В этой таблице можно выполнять при помощи контекстного меню:
Создание, сохраннение и печать как индивидуального паспорта прибора, так и паспорта комплекта не более, чем из пяти приборов, назначить фотографию каждому типу прибора, просмотр назначенных фотографий. Для просмотра нужно включить "Режим Фото".
Удаление или замену этих фотографий, как по отдельности, так и все в один клик.

Присоединение фотографий к типам приборов.
Выберите пункт в контекстном меню:
Фотография прибора > Присоединить к типу и марке.
Найдите нужную фотографию в открывшемся проводнике. Фотография будет присоединена ко всем приборам этого типа. Присоединяется копия файла. Вы сразу же будете видеть эту фотографию. Для закрытия режима просмотра фото снимите отметку "Режим фото". Панель фотографий закроется. Для просмотра - отметьте этот чекбокс и укажите на выбранную строку. На панели отобразится загруженная фотография прибора.

Удаление фотографии выполняется так же. При удалении фотографий Ваши фотографии с диска не удалятся - только их программные копии.

Создание паспортов приборов.
Выделите строку с нужным прибором.
Вызовите контекстное меню правой кнопкой мыши по таблице.
Выберите пункт:
Документы > Паспорт прибора > Автозаполнение и печать.
Паспорт прибора будет сформирован и распечатан.
Выберите пункт:
Документы > Паспорт прибора > Создать в редакторе.
Документ будет сформирован и открыт. Здесь вы можете внести необходимые поправки, сохранить и распечатать паспорт.
Выберите пункт:
Документы > Паспорт комплекта > Основной прибор.
Документ будет создан. Выбранный прибор будет указан в паспорте основным в комплекте. В появившемся окне придайте имя комплекту. В следующем окне будет предложено продолжить.
Выделите следующий прибор и Выберите: Документы > Паспорт комплекта > Добавить. Прибор будет добавлен вторичным. Так можно создать паспорт до пяти приборов или остановиться на любом.
При отказе продолжать или по достижении пяти приборов, в редакторе будет открыт паспорт комплекта. Его также можно редактировать, сохранять, печатать.
Эту таблицу можно экпортировать в файлы или отправить на принтер напрямую.
Экспорт таблицы в Excel и Word не требует объяснений.

Счетчики статуса поверки.
На этой вкладке, внизу, на панели "СОСТОЯНИЕ ГП" расположены счетчики статуса поверки приборов.
Счетчики разделены на группы:
Метрология- условно первые четыре вкладки программы.
Объекты- соответственно на всех объектах базы.
Внешние связи- соответственно в списках внешних организаций.
Всего - суммарные значения счетчиков.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Отчеты

Мониторинг КИП. Организация.

ОТЧЕТЫ.

Трехрежимная вкладка.
Переключение между режимами вкладки выполняется на панели ОТЧЕТЫ.
Эта вкладка программы работает в следующих трёх режимах:
1. Отчет о поверке приборов. Всё состояние поверки приборов сведено в текстовый вид.
2. Лог событий.
Программа записывает все Ваши действия с приборами, объектами и организациями. От создания до удаления их из базы.
3. История СИ. История событий, выполняемых над конкретным прибором выборочно.

Отчет о поверке приборов.
Все поверочные данные сведены в один текстовый документ.
Его можно сохранить и распечатать.

Лог событий.
Программа ведет лог ваших действий и записывает в него практически всё.
Выберите на панели "Лог событий". Все Ваши действия от добавления до редактирования и удаления будут отображены в хронологическом порядке.
Здесь можно отследить, например, свои ошибки или действия коллег, все запуски самой программы.

История СИ.
Введите номер искомого прибора и нажмите кнопку "История СИ".
В таблицу будет выведена история только одного конкретного прибора в хронологическом порядке событий.
Номер можно вводить как заводской, так и инвентарный.
Для быстрого возврата в таблицу "Лог событий" нажмите справа на панели маленькую кнопку с крестиком.
Следует помнить, что при откате состояния приборной базы на конкретную дату, Лог событий также будет заменён прежним, т.к. история не существующих действий неактуальна.
Для удобного восприятия таблиц лога каждое действие имеет свою окраску. Без окраски остаётся такое действие, как перемещения приборов между таблицами.
Таблицы этой вкладки нельзя сохранить или распечатать.

Очистка лога.
Со временем количество строк в логе увеличивается. Для освобождения таблицы от устаревших данных о действиях и повышения скорости работы таблицы, необходимо его очищать от старых записей.
В настройках программы Администратором задается порог, при котором программа предложит очистить лог.

Системные требования:
Windows All. (From Windows XP to Windows 10)


База и графики

Мониторинг КИП. Организация.

База и Графики.
Программа составит за вас график поверки приборов на любой год.

Составление графика.
Откройте вкладку "График поверки".
Переключателем слева выберите год, на который хотите построить график.
Там же, кнопками выберите группу прибором с нужным статусом поверки.
Если в базе приборы с этим статусом существуют, то будет построен помесячный график поверки.
Таблица осматривает всю базу приборов, независимо от их места расположения в таблицах, даже не загруженных.
Вы можете видеть: расположение этих приборов в базе и даже номер строки в таблице, где они числятся, необходимость их поверки и собственно график. График можно широко редактировать.
Можно исключать из графика приборы, менять месяц отправки в поверку.
Приборы не удаляются из базы, а только скрываются в этой таблице.
Для построения графика на другой год необходимо переключить год и снова вызвать кнопками нужный статус годности приборов.

Редактирование графика вручную.
Если требуется изменить график поверки, то можно:
Скрыть из графика какой-либо прибор, выделив его и нажав кнопку "Скрыть выделенный".
Редактировать календарь графика можно кликнув по нужной ячейке месяца и,
снять отметку или поставить в нужную ячейку любой знак.
Вызвав правой кнопкой мыши контекстное меню, отсортируйте график в нужный вам вид, экспортируйте и распечатайте график поверки.

База и Графики
Для перехода в режим просмотра всей приборной базы с полной локализацией по каждому прибору нажмите кнопку справа "Вся приборная база".
Здесь также можно экспортировать всю таблицу в Excel или Word, а также отправить прямо на локальный или виртуальный принтер.
Кроме того, можно вывести в документ Word всю статистику о вашей базе с подробностями: сколько в базе имеется приборов, каких наименований, типов и марок и с какими параметрами. Эту статистику можно фильтровать по наименованиям, типам и маркам, по характеристикам каждого типа.
Мы, как правило, не знаем сколько средств измерений, какого типа и с какими пределами измерений есть в нашей большой базе. Вручную считать долго и не практично. Теперь за Вас это сделает приложение автоматически. Останется только сохранить и распечатать статистику базы.
Для получения сводной статистики в режиме просмотра "всей приборной базы" правым кликом вызовите контекстное меню. Выберите "Экспорт статистики в Word > Сводная статистика Базы". Приложение выведет в Word всё, что есть в базе и отсортирует по наименованиям, типам, характеристикам. Полученный документ можно сохранить.
Далее:
Выберите критерий поиска из выпадающего списка (например, "по наименованию СИ), введите в поле поиска полное значение для поиска. (например, манометр или блок питания). Регистр символов не имеет значения.
Нажмите кнопку "Показать".
Приложение найдет и выведет на экран все манометры или блоки питания. Контекстным меню задайте следующий фильтр вывода в Word (например: по характеристикам). В полученном документе будет более конкретная статискика по этим приборам.

Системные требования:
Windows All. (From Windows XP to Windows 10)


FTP хранилище

Мониторинг КИП. Организация.

Вкладка FTP хранилище.
Откройте вкладку, заполните воля входа на выбранный FTP.
В крайнем правом поле введите имя директории хранилища.
Не допускается: кириллица, пробелы и символы, запрещенные в именах файлов.
Нажмите на кнопку создания хранилища.
Директория будет создана и Ваша пустая или наработанная до этого база будет в неё выгружена в общее пользование. Для работы с базой её нужно теперь получить из хранилища, а после редактирования она автоматически будет выгружена обратно при закрытии программы.

Кнопка SOS.
Восстановление базы из архива на сервере описано на странице "Нештатные ситуации" .
Подробная работа с FTP хранилищем описана на странице на "FTP доступ" .

Системные требования:
Windows All. (From Windows XP to Windows 10)


Перемещение приборов

Мониторинг КИП. Организация.

Пермещение приборов между таблицами.

Все перемещения строк с приборами между любыми таблицами выполняются методом Drag & Drop. Перетащил и бросил. Траектория дропа - треугольник: Источник > Заголовок > Приемник.
Перейдите, например, на вкладку СКЛАД,
Зацепите курсором мыши строку. Курсор изменит свой вид на зачеркнутый круг.
Не отпуская кнопку мыши, потащите курсор на заголовок нужной вкладки - приемника. При наведении на заголовок вкладки курсор снова поменяет свой вид на лист бумаги со стрелкой, выделится заголовок и откроется вкладка - приемник. На таблице будет только одна широкая строка, даже если в таблице уже есть приборы. Не отпускайте кнопку.
Дотяните курсор мыши на эту строку и отпустите кнопку на строке. Всё!
Строка из таблицы - источника перемещена в новую таблицу. Перемещенная строка добавится последней строкой в приемной таблице. Нумерация строк в ней обновится. Счетчики внизу окна программы также изменятся.
Поступайте так с остальными нужными строками.
Если при переносе вы отпустили кнопку не в том месте, т.е. прервали Drop, то вернитесь в таблицу - источник и повторите попытку. Строка осталась там же.
Если вы перенесли строку не в ту таблицу, то придется таким же образом или вернуть её на место и внимательно повторить перенос, или переместить дальше на нужную таблицу, если это не запрещает логика перемещений. Движение строк внутри таблиц запрещено, т.к. все таблицы можно сортировать по разным критериям, а таблицы с объектами - особые таблицы. Каждый прибор объекта может стоять только напротив своего параметра и никакой сортировке не подлежат, чтобы не было путаницы.
В местах, недоступных для переноса, курсор принимает вид зачеркнутого круга.
Перемещение приборов на объекты выполняется несколько иначе.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Экспорт в файл и печать

Мониторинг КИП. Организация.

Экспорт в файл и печать таблиц.

Таблица каждой вкладки программы может быть экспортирована и сохранена в файл MS Excel, MS Word или распечатана "как есть". Текстовую страницу "Отчет о поверке приборов" можно экспортировать в MS Word или также распечатать.

Экспорт в файл:
Правой кнопкой мыши вызовите контекстное меню.
Выберите "Экспорт таблицы".
Программа сформирует файл экспорта и откроет его.
Если требуется - отредактируйте шрифт, и другие параметры таблицы и сохраните как обычно. При выводе на печать этих файлов выбирайте Альбомную ориентацию страниц.
Таблицы обоих "Конструкторов" экспотируются в MS Excel и Word. При выборе опции прямой печати таблицы отправляются в печать напрямую без появления окна параметров печати. В очередь печати принтера ставятся сразу все страницы таблицы и возможности выбрать печать определенных страниц в этом случае отсутствует. При печати таблицы, содержащей 3000 приборов в очередь печати принтера будет отправлено 60 страниц.

Печать таблиц:
Таблица каждой вкладки программы может быть отправлена на принтер "как есть". При этом нужно учитывать, что все таблицы программы представляют собой непрерывный массив строк без деления на страницы. На этом основании перед выводом на принтер в настройках параметров печати, такие параметры как: "Диапазон страниц" и "Выделенный фрагмент" в диалоговом окне программы отключены. Формирование разделителей страниц выполняется драйвером принтера при отправке задания на принтер. Следовательно, будет распечатано всё содержимое таблицы от первой до последней строки. При выводе на печать используйте Альбомную ориентацию страницы.

Выборочная печать.
Если требуется выборочная печать отдельных страниц документа, то можно поступить так:
Выполнте экспорт таблицы в Word или Excel или установите любую программу, содержащую PDF printer. При выводе на печать у Вас появится возможность печати в файл PDF. Сохраненный PDF файл можно распечатать выборочно.
На выборочную печать можно отправить и отредактированный и сохраненный файл Word или Excel или указав в параметрах печати принтера, нужный диапазон страниц.

Системные требования:
Windows All. (From Windows XP to Windows 10)


Архивы и точки отката

Мониторинг КИП. Организация.

Архивы базы. Точки отката.
Для обеспечения информационной безопасности базы и, для помощи в исправлении множества ошибочных действий оператора, в программу включены опции архивирования и отката.
В архив заносятся: настройки программы, вся база приборов, все списки каталога, все списки объектов и организаций вместе с их приборами, лог программы, номера приборов, пароль Администратора, системные файлы программы MonKipOrg.
Начиная с версии 4.x.x. дополнительно к локальному сохранению резерва базы она резервируется и на сервере пользователей. Это позволит восстановить базу на сервере хранения в случае сбоев сетевого соединения при передаче файлов базы.

Содание архива базы.
Архив базы сохраняется в двух случаях:
Автоматически - каждый раз при запуске программы.
Вручную - действиями оператора.
При запуске программа создаёт архив базы и помещает его к себе в директорию. Имя этого архива - дата и время запуска программы.
Оператор может в любое время, по собственному желанию создать такой архив вручную.
Для этого в верхнем меню выберите:
Работа с архивами > "Создать архив базы данных". Архив получит имя в виде даты и времени его создания.

Восстановление базы из архива. (откат)
Когда оператор программы совершает ряд ошибок, которые долго исправлять, т.е. легче вернуться к предыдущему состоянию базы, он должен в верхнем меню выбрать пункт "Откатить состояние из архива". Желательно перед этим создать архив текущего состояния базы.
База загрузится из архива до мельчайших деталей, программа перезапустится, чтобы считать базу в таблицы и во время запуска вновь создаст еще один архив.
Количество архивов ограничено тридцатью. При достижении порогового значения программа сообщит о достижении предела и предложит удалить один или все старые архивы, после чего создаст текущий архив.
Будьте внимательны при откате базы из архива при использовании FTP хранилища.
Если отображаемая база была получена с сервера FTP с правом полного доступа к редактированию, но Вы её подменили архивной локальной копией, то и на сервер будет возвращена база, восстановленная из архива. Программа Вас об этом предупредит. Интеллект программы определяет ваше право на доступ к полученной базе и не позволит вернуть на сервер базу, полученную для просмотра, даже после её редактирования или отката. Именно поэтому кнопка "Отправить базу" отсутствует. В момент закрытия программы произойдет или не произойдет возврат базы на FTP по решению программы.
Восстановление базы на сервере описано на странице "Нештатные ситуации" .

Удаление архивов.
Удаление архивов базы можно выполнять выборочно по одному или все в один клик. При удалении всех архивов в один клик, для исключения состояния "Без архивов", программа создаст архив текущего состояния базы. Хоть один архив базы, но должен быть. Программа следит за количеством архивных копий базы.

Системные требования:
Windows All. (From Windows XP to Windows 10)